Instalación del Driver Propietario ATI (fglrx) 200M en Debian

E-mail Imprimir PDF
Usar puntuación: / 1
MaloBueno 

La instalación de este driver es bastante sencilla, si bien tiene muchos pasos no exige mayor nivel de conocimiento en el área. Sin embargo, este articulo es meramente referencial puesto que según la versión puede variar.

Esta instalación ha sido probada en Debian Sarge (Old Stable), Etch (Stable) y Sid (Unstable) dando excelentes resultados.

Al momento de escribir esta nota la versión del driver es la 8.40.4 la cual presenta una notable mejora en el rendimiento.

  • Instalación de los paquetes necesarios:

# aptitude install module-assistant build-essential dh-make debhelper debconf libstdc++5 linux-headers-$(uname -r)

  • Descarga del driver desde http://ati.amd.com/support/driver.html para la tarjeta Radeon Xpress 200m
  • Crear los archivos .deb de la siguiente manera
# ./ati-driver-installer-8.32.5-x86.x86_64.run --buildpkg Debian/etch
  • Una vez creados se deben instalar los .deb
# dpkg -i *.deb
  • Opcionalmente podemos agregar las siguientes líneas al final del archivo /etc/X/xorg.conf
Section "Extensions"
Option  "Composite" "Disable"
EndSection
  • Procedemos a la integración del driver con el núcleo del sistema operativo.
# cd /usr/src
# m-a prepare
# m-a a-i fglrx
  • Finalmente ejecutamos el asistente para la configuración final:
# aticonfig --initial
# aticonfig --overlay-type=Xv

Eso debería ser mas que suficiente.

  • Ahora para verificar la aceleración 3D ejecutamos el siguiente comando:

$ glxinfo | grep render

y obtendremos el siguiente resultado

Warning, xpress200 detected.
direct rendering: Yes
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX+/3DNow!+/SSE2 NO-TCL

Tomado de: http://www.linuxquestions.org/questions/showthread.php?t=512356

Actualización 15/11/2007

Recientemente actualice el driver fglrx 8.42.3-1 en mi Debian SID y  empezo a dar el siguiente error:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Si esto te sucede, los pasos a seguir son los siguientes:

# rm /usr/lib/libGL.so*
# rm /usr/X11R6/lib/libGL.so*
# cd /usr/X11R6/lib
# cp /usr/lib/fglrx/diversions/lib/libGL.so.1.2 .
# ln -s libGL.so.1.2 libGL.so.1
#  ln -s /usr/lib/fglrx/diversions/libGL.so.1.2 /usr/lib/libGL.so.1
# ldconfig

http://wiki.cchtml.com/index.php/Debian_Installation_Guide

Comentarios (0)
¡Sólo los usuarios registrados pueden escribir comentarios!